I’m really proud that I successfully did my first open-source contribution to a “relevant” project. While trying to create a swagger client library for the dart language I noticed, that the generated code wasn’t working on Flutter. The reason for this is the lack of dart:mirrors support in the flutter framework. The generated code was using dartson which relies on dart:mirrors.

I reworked the dart client that it doesn’t rely on dartson, but works without any further dependencies (pull request).

I know, +8.000 lines doesn’t sound good, but this is the generated sample code for a flutter app mostly.

Categories: Main

Leave a Reply

Your email address will not be published. Required fields are marked *